BBQ GURU CYBERQII User Guide V1.12 for CyberQII Control Interface V1.04
1. DESCRIPTION .................................................................................................................. 3
2. CyberQII and Control Interface - USB, Network and Operating System Compatibility, Features and Limitations .......................................................................................................................... 3
2.1. USB .................................................................................................................................................. 3
2.2. Networkability .................................................................................................................................. 3
2.3. Operating Systems .......................................................................................................................... 3
4. INSTALLING THE CYBERQII CONTROL INTERFACE FEATURES ........................................................................................................................................................................... 3
3. INSTALLING THE CYBERQII CONTROL INTERFACE ON YOUR COMPUTER FROM A CDROM PROVIDED BY THE BBQ GURU .......................................................................................................................... 3
3.1. Quick Startup Guide for use with CDROM installation .................................................................... 5
4. INSTALLING THE CYBERQII CONTROL INTERFACE ON YOUR COMPUTER FROM AN EMAILED UPDATE FROM THE BBQ GURU .......................................................................................................................... 6
4.1. Copying the install software to your Desktop .................................................................................... 6
4.2. Installation of the CyberQII Control Interface PC application .......................................................... 7
4.3. Installation of the Microsoft .NET Framework (if your computer doesn’t already have it) ................. 9
5. INSTALLING THE CYBERQII CONTROL HARDWARE ON WINDOWS 7 ........................................... 16
6. INSTALLING AN UPDATED VERSION OF THE CYBERQII CONTROL INTERFACE ............................................. 17
7. CONNECTING YOUR CYBERQII TO YOUR LAPTOP/COMPUTER ....................................................... 18
7.1. Direct USB Connection to a PC ........................................................................................................ 18
7.2. Connection Using a USB Extension Cable to a PC ............................................................................ 19
7.3. Connection Using a USB Extension With CAT-5 Cable to a PC ....................................................... 19
7.4. Connection Using a Wireless USB Hub ............................................................................................ 19
7.5. Connection Via USB Over Wireless or Wired Network .................................................................... 20
7.6. Connection Via USB Over the Internet .......................................................................................... 21
7.7. Controlling the CYBERQII from your iphone .................................................................................. 21
7.8. Troubleshooting USB Connections ................................................................................................ 22
7.8.1. Troubleshooting a “USB Problem” or “CyberQ not found on USB port” error in the CyberQII Control Interface ........................................................................................................... 22
7.8.2. Troubleshooting a “USB device not recognized” message ............................................................ 22
7.8.3. Troubleshooting a “Device Cannot Start - Error Code 10” messages (advanced) ......................... 22
8. THE BBQ GURU CYBERQII CONTROL INTERFACE FEATURES ...................................................... 23
8.1. Resizing the Dashboard ................................................................................................................... 23
9. DASHBOARD FUNCTIONS ............................................................................................................. 24
10. ALARM STATUS BAR ..................................................................................................................... 24
11. PIT 1 & PIT 2 ATTRIBUTES ........................................................................................................... 24
12. CONTROLLER SETUP ...................................................................................................................... 25
12.1. Battery Power, Alarm Beeps, Back Light ........................................................................................ 25
12.2. Proportional, Ramp OffSet, Cycle Time, Alarm Deviation, Temp Units ....... 25
13. THE PIT AND FOOD TEMPERATURE GRAPH .................................................................................. 25
13.1. Connecting, Disconnecting and Exiting the Application ................................................................. 25
13.1.1. Connecting ................................................................................................................................. 25
13.1.2. Disconnecting ............................................................................................................................ 25
13.1.3. Exiting the Application ............................................................................................................. 25
15. Viewing Key Indicators and the Chart .............................................................................................. 26
15.1. Key Indicators Only ....................................................................................................................... 26
15.2. Chart Only .................................................................................................................................... 26
16. Application Configuration Settings .................................................................................................. 27
16.1. Chart Attributes ............................................................................................................................ 27
16.2. Writing Chart Data Files for Import to Excel .................................................................................. 27
16.3. Importing Chart Data Files to Excel ............................................................................................ 28
16.4. Application Refresh Time .............................................................................................................. 28
16.5. E-Mail Alerts ................................................................................................................................... 28
16.6. Sending Emails to your cel phone as text ..................................................................................... 30
16.7. Change Settings Wait Time .......................................................................................................... 30
16.8. Header Labels ................................................................................................................................ 30
16.9. Firmware Update Location ........................................................................................................... 31
16.10. Configuring the Com Port ............................................................................................................ 31
16.11. Configuring the PC’s Alarm Beeping ........................................................................................... 33
17. Application Actions .......................................................................................................................... 33
17.1. Resetting the Chart ....................................................................................................................... 33
17.2. Update Unit Firmware .................................................................................................................. 33
18. Help ................................................................................................................................................. 34
18.1. About ............................................................................................................................................ 34
19. Software Developer Information ...................................................................................................... 34

Important Note: This User guide deals with the Control Interface PC application only (software). For information on how to use the CYBERQII control unit, please refer to the BBQ Guru CyberQII User Guide.

Page 2
1. DESCRIPTION
The CYBERQII is one of the most advanced BBQ controls on the planet. It is called the CYBERQII because it can be used to control two pits simultaneously. You can access it using this Control Interface through cyber space from any remote location, or use it locally with your PC.

2. CYBERQII and Control Interface - USB, Network and Operating System Compatibility, Features and Limitations

2.1. USB
The CYBERQII’s USB interface is like that of a digital camera, in that it requires a PC to send and receive data. It cannot be directly connected to a router and accessed over a network or the internet, due to the limitations of USB and its protocols. It is not a web server. It does not have an IP address. It is a slave USB device. The CyberQII uses the USB CDC ACM (universal serial bus communications device class abstract control model) protocol, which emulates a virtual communications port on the PC. This interface was chosen to facilitate the ease of user development and maintenance of the PC application source code.

2.2. Networkability
Remote Desktop - The CyberQII Control interface can be accessed using remote desktop applications via another PC or a cell phone that resides on the same network as the PC that the CyberQII is connected to. The remote desktop feature in Windows Xp Professional must be turned on to do this. Setup for remote desktop on the iPhone is described in this user guide. Some versions of Vista and Windows7 also support remote desktop and there are many articles on the web that describe how to accomplish this. There are also USB over network and USB over internet applications that are described in the user guide.

2.3. Operating Systems
The CyberQII control interface can be installed and will run on Windows Xp, Windows Vista, or Windows 7 PCs. Installation on Windows 7 is described in this user guide.

2.4. BBQ GURU CYBERQII CONTROL INTERFACE FEATURES
- Provides a single Dashboard display. This graphical, easy-to-read display of all the control’s measurements and setpoints are shown on one screen of your laptop or computer when connected to the CYBERQII control.
- Exports Chart Data to Excel.
- Allows you to monitor and even make adjustments to all setpoints and all other settable values from a remote location, enabling you to control your cook even while away from the cook site.
- Real-time graphing of all of the temperature sensors and fan outputs.
- More than one control unit can be monitored by opening corresponding numbers of Control Interface instances.
- Open Source Code in C#.NET and the project file for Microsoft Visual studio is available free of charge to experienced programmers for limited, non-commercial use. Contact theBBQGuru.com for more details.

3. INSTALLING THE CYBERQII CONTROL INTERFACE ON YOUR COMPUTER FROM A CDROM PROVIDED BY THE BBQ GURU
System Requirements:
Computer with:
- Windows XP, SP2 or later with .NET Framework V3.5 or later.
- A USB port
- CD ROM /DVD Drive
- A screen resolution capable of 1024 x 600 or better
- Internet Connection (to download Microsoft .NET framework if needed)
- USB cable
- CyberQII Controller
- CyberQII Control Interface Install CD
3.1. Quick Startup Guide for use with CDROM installation

1. Insert the CYBERQII Install Disk in your computer.
2. The setup screen should automatically appear. If it does not, open window explorer & navigate to the CDROM drive. Click setup.exe.
3. Follow the setup screen instructions and if needed, consult the user guide supplied on the CDROM. Once the installation is complete, proceed to step 4.
4. Using the supplied USB cable connect the CYBERQII to the PC's USB port.
5. Apply power to the CYBERQII.
6. The found new hardware dialog box will pop up and show the CYBERQII and then Communications Port.
7. The found new hardware wizard will then open. Do not connect to the radio button - click the radio button - not at this time. Click Next.
8. The hardware installation screen will pop up. Click Continue Anyway.
9. Please wait while the wizard installs the software and Communications Port will appear. Click Finish and then click on the CYBERQII Control Interface Icon on your desktop to run the CYBERQII application.
4. INSTALLING THE CYBERQII CONTROL INTERFACE ON YOUR COMPUTER FROM AN EMAILED UPDATE FROM THE BBQ GURU

System Requirements:
Computer with:
- Windows XP SP2 or later
- a USB port
- CD ROM /DVD Drive
- a screen resolution capable of 1024 x 600 or better
- Internet Connection (to download Microsoft .NET framework if needed)
- USB cable
- CyberQII Controller

Installation will be done in several phases:
1. Copying the install software to your desktop
2. Installation of the Microsoft .NET Framework (if your computer doesn’t already have it)
3. Installation of the CyberQII Control Interface PC Application
4. Installation of the CyberQII Control Unit Hardware

We will go through these steps in detail in the following sections.

4.1. Copying the install software to your Desktop
If you received a CD ROM of the Setup files, Do not use this setup procedure. Follow the Quick start guide provided on the CYBERQII install CD or shown above.

If you downloaded the Setup files, copy the install setup.zip file to your desktop.

If windows shows that the file is blocked, right click the setup file to open the file properties and click on Unblock.

Double Click the zipped setup folder and your screen will show:
Click Extract All Files, then double click the new folder and your screen will show:

Click Setup and follow the instructions on each screen.

4.2. Installation of the CyberQII Control Interface PC application
Double click the Setup folder on your desktop and your screen will show:

Double click Setup and your screen will show:
Click Next and your screen will show:

Click next and your screen will show:
Once the installation is complete your screen will show:

Click Close.

4.3. Installation of the Microsoft .NET Framework (if your computer doesn’t already have it)

If you have a version earlier than 3.5, you should upgrade by downloading the latest version from the Microsoft website.

If you computer doesn’t have the .NET Framework, windows will go to the MSDN website and download it. If you already have it, skip this section.
Windows will ask your permission to download the .NET Framework:

Click Yes and Windows will go to the web and show:

Click Install It Now; your screen will show:

Click Run and your screen may show:
Click Run and your screen will show:

And then:

Select “I have read..”, click Install and your screen will show:
When download is complete your screen will show:
Click Exit and your screen will show:

![Microsoft .NET Framework 3.5 SP1 Setup](image)

Click Restart Now.

4.4. Installation of the CyberQII Control Unit Hardware

Attach the small end of the USB cable to your CyberQII and plug the large end into a USB2.0 compliant port on your computer then apply power to the CyberQII controller. You should hear two tones (low then high) on your PC to confirm connect. If you hear three tones of the same pitch or see a “Unrecognized Device Error” this means a bad connection. Do not unplug and replug the USB connector, press the power key on the Cyber QII to power down and then press it again to power back up. If you cannot get a good connection see the Troubleshooting USB Connections section of this document.

Once connected, a found new hardware dialogue box will appear at the bottom right of your screen.

Then your screen will show the Found New hardware Wizard:
Select “No, not this time” and click Next.

The second Found New hardware Wizard screen will then appear:

Select “Install from a list...” and click Next:

The third Found New hardware Wizard screen will then appear:
Browse to “C:\Program Files\The BBQ Guru\CYBER QII Control Interface\”:

Click Next and your screen may show the hardware installation box confirming verification:

The fourth Found New hardware Wizard screen will then appear:
The fifth Found New hardware Wizard screen will then appear:

Click Finish.

Congratulations! The Cyber QII is now completely setup on your PC!

5. Installing the CyberQII Control Hardware on Windows 7

System Requirements:
Computer with:
- Windows 7, 32 or 64 Bit with .NET Framework V3.5 or later
- A USB port
- CD ROM / DVD Drive
- A screen resolution capable of 1024 x 600 or better
- Internet Connection (to download Microsoft .NET framework if needed)
- USB cable
- CyberQII Controller
- CyberQII Control Interface Install CD
Installing the USB Driver (have the CyberQII control interface CD in your CD drive):
Plug the Cyber QII into the USB port -> Error "device driver software was not successfully installed" may appear; To force install:

1) ENTER DEVICE MANAGER:
   A) Click on the round windows icon at the lower left hand corner of your desktop
   B) In the search field, type "device manager"
   C) In the list above click device manager

2) ENTER CYBERQII PROPERTIES AND UPDATE DRIVER
   A) Under other devices, double click the cyberQ2 with the "CYBERQ II !" to enter properties
   B) Click Update Driver
   C) Click Browse my computer...
   D) Click browse and select the CD ROM drive showing the BBQ GURU logo -> Click OK
   E) Click Next
   F) Windows Security will prompt you if you want to install this device software -> Click Install
   G) The window should display Installing Driver Software
   H) The window should show "Windows has successfully updated your driver software...Communications Port"

Your USB driver is successfully installed for the USB port you have the CYBER QII connected to. If you move the CYBER QII to a different USB port, you may have to repeat this process.

6. INSTALLING AN UPDATED VERSION OF THE CYBERQII CONTROL INTERFACE
Before installing a new version of the CyberQII Control Interface you must first uninstall the old version:

Click Start > Control Panel > Add or remove Programs > CyberQII Control Interface > Remove
Select Cyber QII Control Interface and Click Remove.
The Cyber QII Control Interface is now removed and can be updated or reinstalled.
Now you may install the new version per the instructions in the previous sections of this document.

7. CONNECTING YOUR CYBERQII TO YOUR LAPTOP/COMPUTER
There are five different ways this user guide will show you how to connect your CyberQII and a PC:
Direct USB Connection to a PC (Difficulty: EASY).
Connection using a USB extension cable to a PC (Difficulty: EASY).
Connection using a Wireless USB Hub (Difficulty: AVERAGE).
Connection via USB over wireless or wired network (Difficulty: MODERATE)
Connection via USB over the Internet (Difficulty: ADVANCED).

7.1. Direct USB Connection to a PC

System Requirements:
- Laptop, netbook or any computer with:
- Windows XP
To use the Dashboard to monitor/manage your cook(s) using your computer, connect it as follows.

Note: For all other CYBERQII connections, please refer to the Controller Connections section of the CYBERQII User Guide.

Plug the small end of the USB connector into the leftmost port on the CYBERQII, then large end of the cable into your laptop/computer. Then apply power to the CyberQII. You should hear two tones (low then high) on your PC to confirm connect. If you hear three tones of the same pitch, this means a bad connection. Do not unplug and replug the USB connector, press the power key on the Cyber QII to power down and then press it again to power back up. If you cannot get a good connection see the Troubleshooting USB Connections section of this document.

Open the CYBERQII Control Interface application.

Pressing the ON / OFF key on the CYBERQII unit will power up/down the control and will disconnect the USB link.

7.2. Connection Using a USB Extension Cable to a PC

If you want to extend the range of your USB connection, there are many manufacturers such as BAF0 Technologies making USB extension cables. Simple connect the extension cable to your computer, and connect the other end to the free end of the USB cable that is connected to your CYBERQII. You may be able to add multiple extension cables; consult the extension cable manufacturer’s instructions and specifications. Because the configuration has changed, you will need to repeat the steps in the section entitled “Installation of the CyberQII Control Unit Hardware”. You will only have to do this setup once for this configuration.

7.3. Connection Using a USB Extension With CAT-5 Cable to a PC

If you want to extend the range of your USB connection, there are many manufacturers such as SABRENT making USB 2.0 extension cables. The setup is the same as the USB extender in the previous section. These can enable you to extend the range of your CYBERQII to up to 150 feet.

7.4. Connection Using a Wireless USB Hub
If you want to extend the range of your USB connection over a short range without wires, there are many manufacturers making USB wireless hubs such as IOGEAR and the Dlink DUB-9240. Follow the manufacturer’s installation instructions before installing, as some of these types of devices require software drivers. Once the wireless key and hub are properly installed, simply connect the wireless USB key to the pc, and plug the USB cable connected to the CYBERQII into the hub. You may be able to add extension cables to this if desired. Because the configuration has changed, you will need to repeat the steps in section entitled “Installation of the CyberQII Control Unit Hardware”. You will only have to do this setup once for this configuration.

NOTE: All wireless systems are susceptible to interference. Cordless phones and wireless routers are the biggest causes of interference for wireless computer devices.

7.5. Connection Via USB Over Wireless or Wired Network

If you would like to have the CyberQII plugged into a local PC like a notebook and run the CyberQII Control Interface software on a Network PC you will need a piece of software that is available from many companies (such as Fabula Tech) called a USB Over Network. You simply setup the local PC above to be the server and the Network PC to be the client. The Nework PC will then have direct access to the data on the Local PC’s USB port. Just follow the installation instructions provided with whatever software you choose. The setup takes about 10 minutes and is a very reliable way to setup a remote connection to the CyberQII.
7.6. Connection Via USB Over the Internet

If you would like to have the CyberQII plugged into a local PC and run the CyberQII Control Interface software on a remote PC via the internet, you will need a piece of software that is available from many companies, such as Fabula Tech, called a USB Over Network. You simply setup the local PC above to be the server and the Network PC to be the client. The remote PC will then have direct access to the data on the local PCs USB port. Just follow the installation instructions provided with whatever software you choose.

Another solution to running your CYBERQII remotely is a PC Anywhere type solution. With this type of solution, the CYBERQII software is actually running on the local pc and the remote pc has access to change anything on the local PC.

7.7. Controlling the CYBERQII from your iphone

With the iPhone you can access the PC that has XP Professional installed.

Download mocha soft iphone application [http://www.mochasoft.dk](http://www.mochasoft.dk) for free (for now) into I tunes and download it to your iphone.

If you haven’t already, install the CyberQ software on a PC that has XP Pro. (XP Pro is required for most remote desktop apps, so you may want to upgrade to XP pro if you do not have it.)

Go to control panel -> system ->remote tab.

In the remote tab check "Allow remote users to connect to this PC remotely"

Open the mochasoft iphone application.

On the iphone tap connect (at the upper right). Set the ip address for the PC with the CyberQ application on it. (go to ms dos prompt and type ipconfig/all; this will tell you the local ip address of the PC with the Cyber App on it). Enter your user name and password for the PC. If you don’t have a password setup on your PC you will get the Error Message: “Unable to Log You on Because of an Account Restriction”. In that case, follow Microsoft’s bulletin: [http://support.microsoft.com/kb/303846](http://support.microsoft.com/kb/303846)

Using the mochasoft iphone app, you should be able to successfully log in to your PC and control CyberQII control interface from your iphone. It shows all of the charting and sliders, and you can make adjustments.
7.8. Troubleshooting USB Connections

7.8.1. Troubleshooting a “USB Problem” or “CyberQ not found on USB port” error in the CyberQII Control Interface

1. Make sure that the Cyber Q II is plugged into your USB port properly.
2. Make sure you have installed the USB drivers properly by consulting the “Quick Startup Guide for use with CDROM installation” section of this document.
3. Consult the 3 sections “The proper sequence for connecting your CYBERQ2 to a PC”, “Troubleshooting a “USB device not recognized” message” and “Troubleshooting a “Device Cannot Start - Error Code 10” messages (advanced)”.
4. If the CyberQII is enumerated on the USB port and shows up as a com port in device manager and device manager says it is working correctly, then you may have a conflict with other com ports on your PC. Consult the “Configure Com Port” section of this document.

7.8.2. The proper sequence for connecting your CYBERQ2 to a PC

5. Plug the small end of the USB connector into the leftmost port on the CYBERQII, then large end of the cable into your laptop/computer.
6. Then apply power to the CyberQII. You should hear two tones (low then high) on your PC to confirm connect.
7. If you hear three tones of the same pitch, this means a bad connection. Do not unplug and replug the USB connector, press the power key on the Cyber QII to power down and then press it again to power back up. If you cannot get a good connection see the sections below:

7.8.2. Troubleshooting a “USB device not recognized” message

8. If you get a unregonized device error, do not unplug and replug the USB connector, press the power key on the Cyber QII to power down and then press it again to power back up. Try this several times.
9. If you still cannot get a good connection, eliminate any USB hubs from the link, and make sure that the USB connectors are inserted completely on the PC and the CYBERQII. Press the power key on the Cyber QII to power down and then press it again to power back up.
10. If you still cannot get a good connection and are using a notebook, try disconnecting the charger from the notebook (it may be causing interference). Press the power key on the Cyber QII to power down and then press it again to power back up.
11. If you still cannot get a good connection and are using a notebook, try turning off your wireless internet connection (it may be causing interference). Press the power key on the Cyber QII to power down and then press it again to power back up.
12. If you still cannot get a good connection, try replacing the USB cable. Press the power key on the Cyber QII to power down and then press it again to power back up.
13. If you still cannot get a good connection, try the suggestions in the next section.

7.8.3. Troubleshooting a “Device Cannot Start - Error Code 10” messages (advanced)

14. If you haven’t been able to get a good connection to the CyberQII:
15. Open Device Manager is open, and select the CyberQII (Communications Port) that has the Problem.
16. You can perform some recommended resolutions through Device Manager.
17. Right-click My Computer, and then click Properties.
18. Select the Hardware tab, and then click Device Manager.
19. Double-click the Ports (COMM&LPT) type that has the problem. It will appear as a Communications Port (COM XX).
20. If there is a problem with the CyberQII, it will have a red exclamation point next to it. If a device
is unknown (usually because of missing drivers or a startup problem), the device has a yellow question mark next to it.

7. Right-click the CyberQII that has the problem, and then click Properties. This opens the device Properties dialog box. You can see the error code in the Device status area of this dialog box.

8. From here you can reinstall the drivers or delete and reinstall the Communications Port per the “Installation of the CyberQII Control Unit Hardware” Section of this document.

9. If you still cannot get a good connection try the suggestions in the previous section – “Troubleshooting an Unrecognized Device” Error.

8. THE DASHBOARD
The Dashboard provides a single-screen display of every menu on the CYBERQII unit, plus a real-time temperature graph.

With the probes connected and the CYBERQII unit powered on and connected to the computer, you will be able to use the Dashboard to easily monitor and control your cook(s).

Below is an example screen.

8.1. Resizing the Dashboard
The Dashboard is designed to start up with a 1024 x 600 size window, which is compatible with most netbook PC screens. You can make it larger or smaller by dragging the margins or corners.
9. DASHBOARD FUNCTIONS

10. ALARM STATUS BAR
Alarm messages will be displayed in the bar across the top of the application in red. Please refer to the Status Screens section of The BBQ Guru CYBERQII User Guide for a detailed description of all possible messages.

11. PIT 1 & PIT 2 ATTRIBUTES
The top Right section allows you to set all values for Pit 1. You can use the Dashboard to set these values; simply use the slider bars or checkboxes. Please refer to the following table to access detailed information about the usage of each of these as they correspond to the CYBERQII unit User Guide.

Please note that when using the Dashboard to set values, the values may take several seconds to update.

<table>
<thead>
<tr>
<th>PIT 1 ATTRIBUTE:</th>
<th>REFER TO SECTION OF CYBERQII USER GUIDE:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Food 1 Setpoint</td>
<td>Food 1 Set Screen</td>
</tr>
<tr>
<td>Pit 1 Setpoint</td>
<td>Pit 1 Set Screen</td>
</tr>
<tr>
<td>Pit 1 Hold</td>
<td>Pit 1 Hold Set Screen</td>
</tr>
<tr>
<td>Cook Timer 1</td>
<td>Timer 1 Set Screen</td>
</tr>
<tr>
<td>Timeout</td>
<td>Timeout Action 1 Set Screen</td>
</tr>
<tr>
<td>Alarm 1</td>
<td>Alarms 1 Set Screen</td>
</tr>
<tr>
<td>Ramp 1</td>
<td>Ramp 1 Set Screen</td>
</tr>
<tr>
<td>Open Lid 1</td>
<td>Open Lid Detect 1 Set Screen</td>
</tr>
</tbody>
</table>

This bottom right section allows you to set all values for Pit 2, if you are running a second cook.
These values correspond exactly to those described in the *Pit 1 Attributes* section described above. Please refer to that section for information on setting these values for Pit 2.

Please note that when using the Dashboard to set values, the values may take several seconds to update.

### 12. CONTROLLER SETUP

All parameters for the setup of the CYBERQII will be displayed under the Controller Setup section.

#### 12.1. Battery Power, Alarm Beeps, Back Light

For detailed information on the Battery Power, Alarm Beeps, and Back Light settings, please refer to the *Battery, Backlight, Beeper and Display Setup* section of the CYBERQII User Guide. To set the values using the Dashboard Control Interface, use the slider bars.

#### 12.2. Proportional, Ramp OffSet, Cycle Time, Alarm Deviation, Temp Units

For detailed information on the Proportional, Ramp OffSet, Cycle Time, Alarm Deviation and Temp Units settings, please refer to the *Super User* section of the CYBERQII User Guide. To set the values using the Dashboard Control Interface, use the slider bars, and button for Temp Units.

### 13. THE PIT AND FOOD TEMPERATURE GRAPH

The graph charts the temperature and is always displayed in the bottom left corner.

The graph is a very handy feature to monitor your cook easily. Updated in real-time, it charts the changes in temperature of your pit(s) and food.

The graph is customizable. You can choose which parameters to chart (please refer to the *Chart Attributes* section of this document).

### 14. Connecting, Disconnecting and Exiting the Application

#### 14.1. Connecting

To establish a connection between the CYBERQII unit and the Control Interface, click File > Connect. You can also click the red “Connect” indicator at the top left. The Control interface will make automatic attempts to reconnecting to the control if it becomes disconnected.

Once the unit is connected to the PC with the USB cable, the “Disconnect” indicator will be displayed in red at the top left of the application.

#### 14.2. Disconnecting

To disconnect the CYBERQII unit from the PC, click File > Disconnect. You can also click the red “Disconnect” indicator at the top left.

#### 14.3. Exiting the Application

To exit the application, click File > Exit. You can also click the standard Windows red X at the top right of the Control Interface window.
15. Viewing Key Indicators and the Chart

15.1. Key Indicators Only
To open a new window to display just the key indicators, click View > Key Indicators Only. You can also press F1. It will display your alarms and key attributes for each pit in large text format.

Key Indicators Only screen:

<table>
<thead>
<tr>
<th>Pit 1 68</th>
<th>Pit 2 68</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pit 1 Set 159</td>
<td>Pit 2 Set 200</td>
</tr>
<tr>
<td>Brisket 68</td>
<td>Ribs 68</td>
</tr>
<tr>
<td>Brisket Set 205</td>
<td>Ribs Set 205</td>
</tr>
<tr>
<td>Fan1 100%</td>
<td>Fan2 100%</td>
</tr>
<tr>
<td>Cook1 00:00</td>
<td>Cook2 00:00</td>
</tr>
</tbody>
</table>

Close the Key Indicators window to return to the main application window.

15.2. Chart Only
To open a new window to display just the Pit and Food Temperature Graph, click View > Chart Only. You can also press F2. It will display the chart in large text format.

Chart only screen:
Close the Chart Only window to return to the main application window.

16. Application Configuration Settings

16.1. Chart Attributes

To select which attributes to plot on the Pit and Food Temperature Graph, click Configure > Chart Attributes.

Select which attributes for the chart to plot and click OK.

Your changes will be reflected in the Pit and Food Temperature graph.

16.2. Writing Chart Data Files for Import to Excel

To enable the Chart Data File Writing, check the “Please choose a location to store chart data” box. You can click the browse button and this will choose the location path that the data files will be stored. The data file will be updated at the application refresh rate.
The Data File Format is csv (comma separated values) formatted as follows:
(Pit1 temp),(Food1 Temp),(Fan1%), (Pit2 Temp),(Food2 Temp),(Fan2%)
For example if each line showed: 71,---,100,---,---,0
You know that the Pit 1 temperature is 71 deg, Food1 is not present, Fan1 is 100%, Pit2 is not present, Food2 is not present, Fan2 is 0%.

16.3. Importing Chart Data Files to Excel
Once the data file is created, to import it to Excel follow these instructions:
Open the file from excel as a text file (*.csv) then:
Choose delimited
Click Next
Check the checkbox for comma delimited
Click Finish
The columns will appear in the following order:
| Pit1 temp | Food1 Temp | Fan1% | Pit2 Temp | Food2 Temp | Fan2% |

16.4. Application Refresh Time
To set the refresh rate of the application, click Configure > App Refresh Time.

Enter the time in seconds for the PC application to update itself with data from the CYBERQII control and click OK. Valid values are 0 to 30 seconds.

16.5. Email Alerts
To receive email alerts, for instance to monitor the cook from a remote location, click Configure > Email Alerts.

The following screen will display:
Set up this screen as follows:
Note: If you use Outlook or Outlook Express this information can be obtained from the account setup.

Any SMTP (Simple Mail Transfer Protocol) email will work. The following example uses a gmail account which requires password authentication.

In the SMTP Host (IP Address) field type “smtp.gmail.com”.
In the SMTP Port field type “25”.
In the email address field type the destination email address.
The password is the email account password.
Enable SSL should be checked if your email host requires SSL.
Press the test button to send a test email to the specified email address.
In the alarm email interval box select how often you would like the emails sent to the destination email address.
If you want to start receiving emails, be sure that the Enable Email Alerts Box is checked.

The email will come in the form of the following text:

Alarms: NO ALARMS!
Food1 Temp: 70
Food2 Temp: 71
Food1 Setpoint: 185
Food2 Setpoint: 185
Pit1 Temp: 70
Pit2 Temp: 70
Pit1 Setpoint: 79
Pit2 Setpoint: 79
Fan1: 74
Fan2: 74
16.6. Sending Emails to your cell phone as text:
Here are the steps for sending an email to your phone.

You will need: the company that handles your cell phone service, the cell phone number, and the email extension of the cell phone service provider.

If you are unsure of the cell phone service provider, you can look it up online at http://www.whitepages.com/10866/reverse_phone. Type in the cell phone number and press search. The returned results will inform you of the registered service provider.

Now you can determine the email address. The email address will be the cell phone number followed by the carrier extension. An example email address would be 8565551111@vtext.com for cell phone number 856-555-1111 with Verizon Wireless as a service provider. Some of the more popular cell phone carrier extensions are listed below. The extension can be obtained from your service provider.

Verizon Wireless: (cell#)@vtext.com
AT&T: (cell#)@mobile.att.net
Cingular: (cell#)@mycingular.com
Nextel: (cell#)@messaging.nextel.com
T-Mobile: (cell#)@tmomail.net
Sprint: (cell#)@messaging.sprintpcs.com
Tracfone: (cell#)@cingularme.com

For this to function properly, you will have to have the email address specified in the email alerts be forwarded to your cell phone as a text message.

A superior way to receive email alerts on your phone is to check the email address specified in email alerts with a web-enabled phone.

16.7. Change Settings Wait Time
Settings Wait Time is the time between the adjustments are made and the control is updated.

Example: You change a setpoint. The PC application will wait this period of time before sending the data to the control. This is used to prevent excessive memory write cycles on the controller. To set the time in seconds for the application to wait before applying your changes, click Configure > Change Settings Wait Time.

Enter the number of seconds and click OK. Valid values are 1 to 30 seconds.
16.8. Header Labels
For ease of use, the Pit and Food display parameters in the header section can be made more meaningful by customizing them to the type of food you are cooking. To change these labels click Configure > Header Labels.

Note that the chart will be rest.

Click Yes and enter your desired labels.

Your changes will be reflected in the parameters display section at the top and on the Pit1 and 2 Attributes.

16.9. Firmware Update Location
The firmware of the CYBERQII unit can be updated with a new file available from The BBQ Guru company (please visit http://www.thebbqguru.com). This will ensure your CYBERQII is running the latest firmware. This section describes how to specify a location for that file. Please refer to the Update Unit Firmware section to perform the update. You can download or be emailed the firmware file called
cyberxxxx.hex (where xxx is your serial number) and put the file in any folder you choose. For the PC application to update your firmware, it has to know where firmware it is. You can specify this by selecting the location for the file and clicking OK.

This must be done before you can update your CyberQII unit’s firmware. After completing this step, please proceed to Update Unit Firmware section to complete the process.

Click Configure > Firmware Update Location. Choose the location that you downloaded the file to.

16.10. Configuring the Com Port
Attention: if your CyberQII is connecting Ok, you shouldn’t need to change the com port setting.

The Cyber QII uses a USB connection that emulates a Com port on your PC. The CyberQII Control Interface is designed to scan all of the com ports on your PC and automatically find the CyberQII. Sometimes other hardware and software can interfere with the application’s ability to recognize your CyberQII. This can be resolved by fixing the com port that the CyberQ Communicates.

If you have a “USB Problem” or “CyberQ not found on USB port” error in the CyberQII Control Interface and if the CyberQ shows up in device manager as a comm port and when you click on its properties it says this device is working properly, then this action will fix it 99% of the time. If it shows an error under the device manager properties, then most likely this will not help.

Open device manager, under Ports (COM & LPT), double click the one that the PC assigned to the CyberQ (with the CyberQ plugged in). In the property page, click the Port Settings tab. Click Advanced. Change the COM Port Number to 99 (or any port that is not in use).

In the CyberQII Control Interface select Configure > Com Port. Set the Comm Port to 99 (or whatever you set the Com Port to in Device Manager)

Attention: if your CyberQII is connecting Ok, you shouldn’t need to change the com port setting. Leave this set to 0 (default) for the CyberQII Control Interface to automatically scan for your CyberQII. Any changes made to the Configure Com Port will not take effect until you click disconnect and connect.
16.11. Configuring the PC’s Alarm Beeping

To enable the PC’s Alarm Beeping click Configure > Alarms.

Check the Enable Alarms Box:

Whenever there is a new alarm, the PC will beep until the Stop Alarms button is clicked.

17. Application Actions

17.1. Resetting the Chart

The Pit and Food Temperature Graph may be reset. Click Actions > Reset Chart.
The Pit and Food Temperature Graph will be reset.

17.2. Update Unit Firmware

This section details how to install an updated version of the CYBERQII unit’s firmware (file available from The BBQ Guru company). Please refer to the Firmware Update Location section to specify a location for the update file to reside before you can perform the update.

To update the CYBERQII unit’s firmware:

Obtain the new file form The BBQ Guru company (please visit http://www.thebbqguru.com).
Specify a location as described in the Firmware Update Location section.
Begin with the CYBERQII unit unplugged and the Control Interface closed.
Connect the CYBERQII to the PC with the USB cable.
Plug the power connector into the CYBERQII unit while holding down the Scroll key. The CYBERQII unit’s display will read “DOWNLOAD VX”, X being the Version number.
Open the Control Application.
Click Actions > Update Unit Firmware.
Click Update.
The progress bar will display when the update is complete.

Click Exit when finished.
Close the application.
Power down the CYBERQII.
Restart the application and power up the CyberQII.

18. Help

18.1. About
Click Help > About to view information about the CYBERQII Control Interface Application.

19. Software Developer Information
The CyberQII Control Interface was programmed in C#.NET (C sharp .NET) using Microsoft Visual Studio. For users that have technical programming know-how, the program source and project files can be obtained from thebbqguru.com free of charge. Since this is “open source”, you be able to work with the user interface, customize the graphics and operation using Microsoft Visual studio. The only restriction to the open source code availability is that it may not be resold or used commercially in any way, but may be freely distributed and shared for use with the CyberQII Controller.